Can’t invest with ChipX free trial

Hiya, first of all, really sorry if this has been posted before. I did search for the same problem posted by others and couldn’t find anything.

My problem is that as a result of being an investor I’ve recently been moved onto a free trial of Chip X - I recently added the “clean energy” fund to my ISA and tried to invest, but I got a message to say that I can’t invest in this because I need to downgrade to ChipAI. I opted to downgrade just to see if that resolved my problem, and it didn’t I’ve tried multiple funds and can’t invest in any of them. I hope I’ve given enough information to be helpful. Happy to provide more if you need. :slight_smile:

Thanks in advance
Howie

I’m just bumping this, it’d be nice to hear if there’s a solution?

1 Like

Hey Howie,

Sorry to hear about this! If you could send me a private message on this forum with the email address that is connected to your chip account, that would be great. I will pick up this issue with our operations team first thing on Monday. Apologies for my slow response on this. Hope you have a great weekend.

Your Community Manager,
Fred