Card Declined when making manual deposits

Currently experiencing issues with manual deposits into my chip account.

I am presented with a toast notification informing me that my card has been declined. I’ve spoken to customer support and I’m told this is being worked on currently, but there’s no tracked bug so here it is.

Repro Steps :

  1. Sign in
  2. Press Manual Save
  3. ‘Card Declined’ Toast is presented and deposit is not made.

I should add I’m a Starling Customer and have already confirmed this is not a bank level issue.

I get a notification that Chip couldn’t charge my card for automatic deposits. Have spoken to the team a received the same message - that their developers are working on it. Hopefully it gets fixed soon!!

1 Like

Hi - apologies for this. It’s an issue with our payment provider that is effecting a few users. But, just to confirm nothing is wrong with your card/bank and we are hoping the issue will be solved as soon as possible.

This (automatic and manual saves declined) has been going on (for me) for 26 days. That’s a ridiculously long time to have not dealt with a technical issue!

Join the long list of disgruntled savers

1 Like

I’ve closed my account. I find it unacceptable for a company to give practically zero public acknowledgement or progress updates to customers. This was only made ever more frustrating with their use of an absolutely shocking customer services application ( intercom? )

I’ll be taking my business back to Plum, so long Chip.

Starting working again for me this evening. Added a new card. Donald has been helpful to be fair and I could withdraw cash if I needed to.
I get this all day in IT support, everything works, no thanks, something goes down, it’s the end of world!

I’m not particularly blaming the customer support team, it’s not their code of decision as to what platform the company decides to invest in.

I’m glad you were able to get to your money, I had to jump through several email hoops in order to, each time with varied levels of delay.

It’s not unreasonable for customers to expect a certain level of quality. Especially in the fintech world.

To be fair, i spoke too soon! Manual save worked, but auto didn’t. Apparently there was an update to fix this today but I just got this logging in!

1 Like

Exactly the same issue here

1 Like