Top up Blackrock investment

Hi there,

I am trying to top up my adventurous fund and I keep getting a banking error. Is there an issue with this or is this something to do with my bank? Funnily, the automatic savings that Chip takes every 3-4 days seems to be working with no issues


You may have to wait 24 hours and then try as you can only do 3 attempts on any of the accounts in 24 hours…

1 Like

Still not working - Hsbc! Will have to wait until Tuesday and see what the problem is - annoying though as takes a while for it to filter through the funds. Vanguard is instantaneous (although not fund
Ownership - but 2/3 days max)

Can someone @Chip help with this please, I raised the issue on the app a few days ago and still not working! Bit disappointing as someone who has invested ~£10k in Chip

Since @KrishChip has left, I’m not sure how actively monitored the forum is currently.

It might be worth emailing if you haven’t tried that.


1 Like

Is your account fully linked? Both bank account and debit card?

Cheers chaps! Managed to update my bank details - couldn’t do it on the app but someone finally got in touch so I could update the expiry date! Automatic savings were still fine which threw me a little …

1 Like